logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

Springcloud项目接入cas-server(中央认证服务),含cas-client源码修改,maven工程引入本地jar

springcloud纳入到cas-server管理,cas-client源码修改,maven工程 引入本地jar

文章图片
#spring cloud#maven#jar
mongodb分页排序问题 Sort exceeded memory limit of 104857600 bytes, but did not opt in to external sorting

mongodb分页排序问题 Sort exceeded memory limit of 104857600 bytes, but did not opt in to external sorting。

文章图片
#mongodb#数据库#nosql +1
Rancher部署常用组件-redis、mysql、nacos等

首先选择 环境 - 应用 ,然后添加服务,不了解的可参考上篇Rancher安装redis参考的docker命令docker run --name redis -p 6379:6379 --restart=always -d redis:6.2.6 --requirepass qsxdr123! -v /data/redis/data:/data命令 - 截图命令内容redis:6.2.6redis

文章图片
#redis#mysql#数据库 +2
springboot项目中定时任务注解@Scheduled未按cron表达式执行

在将一个类注入到ioc后,其中定义了几个定时任务,分别是每隔十秒执行一次,但实际情况却是半小时才执行一次,故开始分析原因:spring scheduled默认为单线程,导致任务阻塞,很多时候不能按时执行原因。等待3分钟之后,其他任务均会被执行一次,再次进入等待;看看现在的效果,发现即便是任务2耗时,但不影响其他三个任务,而任务2本身的线程池可自行调整核心线程数与拒绝策略。将执行任务的线程打印,发现

文章图片
#spring boot#java#后端
删除influxdb2的数据存储文件--Win版

Windows版influxdb2的数据存储文件清理

文章图片
#java
调用钉钉api报错:机器人发送签名过期;solution:签名生成时间和发送时间请保持在 timestampms 以内

调用钉钉api报错机器人发送签名过期;solution签名生成时间和发送时间请保持在timestampms以内。

文章图片
#java
linux虚拟机的ens33网卡失效,提示:ens33: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qle

使用命令( sysemctl restart network 、service network restart)重启网卡提示如下。安装的虚拟机挂机,重启宿主机后,虚拟机IP丢失,且重启网络服务时,提示失败。

文章图片
#linux#网络#服务器
虚拟机使用Docker报错:ERROR: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on

虚拟机使用Docker报错:ERROR: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on解决办法:1、vi /etc/resolv.conf2、输入nameserver 114.114.114.114search localdomain3、保存文件即可

文章图片
#docker#容器#运维 +1
docker基础命令大全

简单介绍Docker容器容器类似于windows下的VMware、Hyper-V装的虚拟机;但docker由linux系统实现虚拟化,完整资源隔离;可以快速部署启动应用;一次编写,四处运行(有一定的限制,比如Docker是基于Linux 64bit的,无法在32bit的 linux/Windows/unix环境下使用)安装Docker容器windows下安装docker请看这里linux下安装do

文章图片
#docker#容器#linux
到底了