logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

使用helm安装etcd集群

1、添加helm仓库helm repo add bitnami https://charts.bitnami.com/bitnamihelm pull bitnami/etcd#可以看到安装包已下载到本地2、解压安装包tar zxf etcd-6.13.2.tgz3、修改配置cd etcd#修改密码#修改存储方式persistence:## @param persistence.enabled I

#etcd#kubernetes#docker
hbase常见错误汇总

1、报错信息2014-02-24 12:15:48,507 WARN[Thread-2] util.DynamicClassLoader (DynamicClassLoader.java:<init>(106)) - Failed to identify the fs of dir hdfs://fulonghadoop/hbase/lib, ignoredjava.io.IOExce

#hbase#hadoop#hdfs +1
Kubernetes使用loki+prometheus+grafana实现日志收集与分析

日志收集系统Lokigrafana loki 是可以组成功能齐全的日志记录堆栈的一组组件与其他日志记录系统不同,Loki是基于仅索引有关日志的元数据的想法而构建的: 标签。日志数据本身被压缩并存储在对象存储(例如s3或GCS)中的块中,甚至存储在文件系统本地。小索引和高度压缩的块简化了操作,并大大降低了Loki的成本。基于Loki的日志收集系统Loki- stack子系统Promtail将容器日志

#kubernetes#java#容器 +1
ubuntu20.04修改网卡名称为eth0

1、修改grubvim /etc/default/grub2、更新grubupdate-grub3、修改网卡名称vim /etc/netplan/00-installer-config.yaml4、重启系统reboot5、查看网卡修改成功。

#linux#bash#ubuntu
gitlab报500错误

报错截图点击一个界面,加载好长时间报500解决办法原因分析: 一般加载好长时间后报500,可以确定的就是超时时长引起的,如果是服务内部错误,点击就会瞬间报错,所以调整下超时时间即可。...

#gitlab#linux
gitlab高可用部署方案

背景公司计划将gitlab迁移上云,并部署成高可用方式,下面是gitlab高可用部署的详细方案,希望能对大家有所帮助。架构图部署两个完全一样的gitlab,其中gitlab有关目录的存储使用NAS来实现共享,数据库采用psql主从,访问入口使用slb来提供服务。一、安装postgresql1、环境系统版本:Centos7数据库版本:9.6.11主库:192.168.15.55从库:192.168.

#linux#gitlab
gitlab删除project失败,报错500

1、查看日志找原因#使用下面命令动态打印日志,删除project,看看会报啥错gitlab-ctl tail日志中提示是token不一致导致的,需要修改psql数据库来解决2、修改psql#登录psql/data/postgresql/bin/psql gitlab#查看ci_group_variables 和 ci_variables 表SELECT * FROM public."ci_grou

#linux#gitlab
ubuntu20.04 server安装

镜像下载#可以去ubuntu官网下载指定版本的镜像https://releases.ubuntu.com/20.04/安装系统1、选择语言默认为英语即可2、取消安装更新3、选择键盘语言4、配置ip,可以直接选择dhcp,这里选择配置静态ip5、配置代理,这里不填写6、设置镜像源使用阿里云: https://mirrors.aliyun.com/ubuntu/7、磁盘配置,默认即可格式化磁盘8、设置

#ubuntu#linux#运维
open-falcon监控rabbitmq

1、监控脚本#!/bin/env python#-*- coding:utf-8 -*-__author__ = 'iambocai'import sys, urllib2, base64, json, time,socketstep = 60ip = socket.gethostname()print ipts = int(time.time())keys = ('messages_ready'

#linux#运维
containerd使用ctr导入镜像成功,crictl为何查询不到?

1、使用ctr导入镜像ctr image import dashboard.tar#查询镜像,为什么没有刚才导入的镜像?crictl images2、原因分析ctr是containerd自带的工具,有命名空间的概念,若是k8s相关的镜像,都默认在k8s.io这个命名空间,所以导入镜像时需要指定命令空间为k8s.io#使用ctr命令指定命名空间导入镜像ctr -n=k8s.io image impo

#kubernetes#容器
到底了