logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

微众Linkis1.0整合hadoop3启动报错NoSuchMethodError: org.eclipse.jetty.server...getSessionManager()解决

在这里记录下微众Linkis1.0.0在与Hadoop3.1.1整合时产生的依赖问题,编译没问题,但是在安装完后启动微服务linkis-ps-publicservic时报错,我们看下具体错误:2021-07-23 13:20:39.532 [INFO ] [main] o.s.c.s.PostProcessorRegistrationDelegate$BeanPostProcessorChecke

#大数据
hiveserver2日志配置

刚安装的hive需要到将conf/hive-log4j2.properties.template文件更名为hive-log4j2.properties,并将其内容中的property.hive.log.dir配置项设置为正确的日志路径,这样开启hiveserver2后就会在该路径下看到启动日志

CDH6.x安装教程(附带整合kerberos)

一、安装前准备设置HOSTvi /etc/hosts关闭防火墙sudo systemctl disable firewalldsudo systemctl stop firewalld设置SELinuxvi /etc/selinux/config将SELINUX=enforcing 改为SELINUX=permissive,然后重启服务器,或者执行下面命令:setenforce 0开启NTP服务#

文章图片
#hadoop#cloudera
java连接phonix报错:KeeperErrorCode = NoNode for /hbase/hbaseid

我的phonix jdbc url连接参数值如下jdbc:phoenix:prod-bigdata-pc10:2181/hbase-unsecure可见我在url中已经指定了zk连接端口和hbase节点等信息,由于我是hdp环境,该环境的hbase在zk上建立的根节点为/hbase-unsecure,所以需要指定实际值,但是实际建立phonix连接时仍旧会到zk上找默认的/hbase节点,并且也发

#hbase#java#big data
kafka指定时间范围消费一批topic数据

public class JavaConsumerTool {/*** 创建消费者* @return*/public static KafkaConsumer<String, String> getConsumer(){Properties props = new Properties();props.put("bootstrap.servers", "127.0.0.1:9092")

#kafka#java#分布式
CDH完全卸载教程

适用于各版本CDH卸载1、停止集群

#大数据
到底了