
简介
该用户还未填写简介
擅长的技术栈
可提供的服务
暂无可提供的服务
今天因为涉及到私有化部署,需要把saas服务所依赖的jar包要提供到私有云镜像仓库去。因此先在本地导出一份jar包依赖清单。后面的target/lib可以自行修改到指定目录。2.执行命令即可,记得先在右上方选择下工程。
IDEA进入File | Settings | Build, Execution, Deployment | Debugger 关掉下面的即可。
业务背景:在当前项目下,所有前端请求均通过外层网关转发到后端这边的dubbo服务,现计划去掉网关层,由前端直接http调用后端dubbo。解决方案:在前端调用方式不变的前提下,后端服务新建controller层(原后端服务无任何controller),做统一请求兼容转发。

问题:今天出现一个很奇怪的现象,有个应用引入了别的模块,但是编译一直无法通过,后台提示找不到对应的包,但是明明仓库下是有包的,使用反编译工具查看源码,发现是被引入的jar包,里面的结果错误了,出现 package BOOT-INF.classes.*.*.*.*.*.*类似于这样的包声明。博主的解决办法如下:在打包时,pom文件里添加如下配置,重新打包该依赖模块即可。<plugin>&
包装类的转换问题,博主遇到此异常的场景是:获取一个对象的属性值为null,同时使用==进行比较判断,这样就报这个异常解决办法就是先对要获取的属性,做空指针判断,再进行比对,可以解决!...
mybatis在读取oracle的clob类型字段值时,长度未超过限制的话,使用to_char(clob字段)进ORA-00932,数据类型不一致:应为-,却获得CLOB行转换读取是没啥问题的,但是一旦存储的字段长度超出限制,就会报错,Oracle Error : ORA-22835: Buffer too small for CLOB to CHAR or BLOB to RAW convers
原因:会出现此异常,是由于内存中的对象类型与你想转换出来的时间戳类型不一致造成的,解决办法:1.网上有种解决办法是通过设置系统属性oracle.jdbc.J2EE13Compliant为true,在博主的开发环境下是不行的,依然会出现异常2.采用类的反射:private Timestamp translateTimestamp(Object val) {try {Class c = value.g
2. 勾选你需要挂载的磁盘即可。1.点击本地-详细信息。3.进入远程桌面查看。
博主是在VMware上安装的,简单记录下:1.启动客户机后,乌班图系统会自动进入安装初始化界面从左侧语言栏选择语言,然后点击右侧的Install按钮,进入下一步2.选择键盘布局,这个根据自己喜好,一般默认就行,点击continue3.选择安装模式,第一种是常规模式,会带有浏览器、office软件、游戏、媒体播放器等一系列,和windows安装时附加安装差不多,博主选择第二种,极简模式,安装必要的部
2.2 此时则需要考虑,是非Java应用引起的pod内存上升,经过排查发现,有大量的tail和less命令正在占用内存,而且操作的是实时日志文件,这个文件会自动无限制追加内容的。2.1 首先考虑的是pod里的Java应用本身内存rss是否超限。3.结论:将这些tail及less进行干掉,pod内存恢复正常。今天生产环境触发告警,容器pod的内存上升,达到告警阈值。







