logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

nginx更换https的ssl证书

1.首先将原来的备份,防止万一出问题,能够即使恢复2.阿里云 下载nginx证书3.去nginx下替换:目录 /usr/local/nginx-1.16.0/conf/cert4.更改/usr/local/nginx-1.16.0/conf/nginx.conf 文件,替换为新的证书名称server {listen443 ssl;server_name x.91yixun.com;ssl_cert

#nginx#ssl#https
nacos注册地址为docker内网ip的解决方法

问题:遇到nacos注册地址为docker内网ip,导致跨机服务之间调用失败解决: 修改配置文件spring:cloud:nacos:discovery:ip: 10.168.254.107将服务的ip直接写成固定的,就会自动与寻找这个ip,如果找不到,还是会用原有ip,程序不会报错。还可以加上port端口参数。过程:在网上查找好多都是修改host,这是典型的“解决不了问题,就修改问题的方法”还看

#docker
char(1) 导致 报错 :java.lang.StringIndexOutOfBoundsException: String index out of range: 0

char(1) 导致 java.lang.StringIndexOutOfBoundsException: String index out of range: 0报错ava.lang.StringIndexOutOfBoundsException: String index out of range: 0at java.base/java.lang.StringLatin1.charAt...

#java#sql
钉钉机器人创建详细过程(Java方法)

钉钉机器人:https://blog.csdn.net/java_zyq/article/details/84586317

到底了