logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

clickhouse单节点更改为副本集

将数据从旧表移动到新表(/var/lib/clickhouse/data/db_name/table_name/)目录内的 ‘detached’ 目录中。如果你有一个手动同步的 MergeTree 表,您可以将其转换为可复制表。如果你已经在 MergeTree 表中收集了大量数据,并且现在要启用复制,则可以执行这些操作。如果各个副本上的数据不一致,则首先对其进行同步,或者除保留的一个副本外,删除其

#clickhouse
记一次hivemetastore启动报错

4,最后排查,这个节点rpm部署了hive,现在只是copy了一个hive的目录过来,导致/usr/bin/hive 这个里面和现在部署的安装包不是同一个。3,把hive-site.xml中无关的配置都删掉,重启metastore还是报错。1,启动hivemetastore后报错日志。2,排查lib下的mysql的驱动也在,这里和mysql的驱动大小一样。

文章图片
#hive
clickhouse处理readonly报错

cllickhouse修复readonly遇到问题

文章图片
#clickhouse
clickhouse一次异常排查记录

二,在客户端执行sql:发现问题了,查询中没有带当天分区,所以14亿是全表扫描,有问题,于是添加上day和hour,问题解决。报错中一个是超时,一个是查询数据量有点大14亿,但是表中每一小时都没有这么多。关闭了自启动,删了status,重启了clickhouse还是报错。1,排查定时执行的脚本日志(每小时第5分钟执行)2,查看ck执行异常详细信息统计。clickhouse中报错。解决方法:一是增大

文章图片
#clickhouse
hbase安装部署

hdfs运行在本机,根据实际情况更改localhost。先要启动zk再启动hdfs,最后启动hbase。

文章图片
#hbase#数据库#大数据
idea单元测试报错找不到主类

在下面的command line 中选择jar manifest 因为条参数过长,这里设置只使用主类。主要是单测中没有配置类。

文章图片
Unable to read additional data from server sessionid 0x0, likely server has closed socket, closing

从zoo.cfg看下datadir,将下面的myid改成和zoo.cfg里的自己一样的。这里是3但是本机节点是XX,所以要改成1。那么它的myid必须是1。

文章图片
#服务器#linux#运维
carbondata中查询hive java.net.SocketTimeoutException: Read timed out 问题解

hive.metastore.client.socket.timeout=5000&hive.server.read.socket.timeout=5000&hive.server.write.socket.timeout=5000&hive.server.thrift.socket.timeout=5000&hive.client.thrift.socket.timeout=5000这样查询参数

文章图片
#hive#java#hadoop
clickhouse的删除和更新

虽然Mutation能最终实现修改和删除,但不能完全以通常意义上的UPDATE和DELETE来理解,我们必须清醒地认识到它的不同:首先,Mutation语句是一种“很重”的操作,更适用于批量数据的修改和删除;这很容易理解,如上文提到,更新的单位是分区,如果只更新一条数据,那么需要重建一个分区;clickhouse不擅长更新和删除操作,更新操作很重,更新是重新创建一个分区,更新完后,太混之前的。对于

文章图片
#clickhouse#数据库#java
    共 27 条
  • 1
  • 2
  • 3
  • 请选择