
简介
该用户还未填写简介
擅长的技术栈
可提供的服务
暂无可提供的服务
客户使用tongweb7049部署应用后,应用上传文件 formData 参数超过10 个, 会报错,:Caused by: com.tongweb.web.util.http.fileupload.FileCountLimitExceededException。
此贴参考,是在此帖子的基础和同事整理的文档的基础上重新部署验证的优化版,使用的是centos7。优点:不需要通过jmx配置进行监控。思路:zabbix可通过tongweb的reset接口获取相关信息,然后根据获取的json信息,提取出需要监控的数据。

备份好tongweb,然后将tongweb安装目录/lib下ecj.jar复制到lib/extend目录下,改名覆盖tongweb-jdt.jar,重新启动即可。为了解决JDK17上jsp编译的问题,M10升级了jsp编译器,导致无法编译特定的 JSP。
cd到helm目录的上一级目录,执行以下指令(其中default是k8s的命令空间,tongweb是指release_name,如果需要用其他的命令空间,可以使用指令:kubectl create namespace 自行创建)。到解压好的tongweb7的目录下,在对应路径找到chart.yaml(最好是自己单独复制一个helm目录出来去执行,这里只是为了演示方便)查看日志没问题的话,打包和pu

两种情况的区别只在于是否配置conf目录下的httpserverHA.conf(里面要配网卡信息,浮动ip信息等),本质都是直接解压THS的安装包(例如x86环境下的TongHttpServer_6.0.1.3_x86_64.tar.gz),解压后放入授权文件,执行脚本启动(单机版和集群高可用都需要执行./start.sh 进行启动 ,高可用的还需要执行./startHA.sh)。这是因为控制台限

如果配成true,需自行百度一下如何配置elasticsearch的密码(有很多个用户的,例如elasticsearch用户,这里为了方便测试,所以没用配置密码的形式,因为配置后,后面的skywalking的apm上也要配置,很麻烦)使用了Tongweb7嵌入式版本p11的应用,本质上就是一个打成jar包的java程序,可以使用java -jar来启动,那么在启动的时候,可以利用skwalking

f12控制台报错Access to XMLHttpRequest at ‘xxx’ from origin ‘xxxx’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header i

本次使用的tongweb版本7049m4,测试包ws_example.war(在tongweb安装目录的samples/websocket下),ths版本6011。在输入框输入以下内容,ip替换为自己的,如果跟上图所示一致,就说明测试成功。

看控制台安裝那一节,配置文件上,记得检查http.yaml的https_enable改一下,改成true。解压后使用ip a查看一下自己的网卡上的ip,本次示范用的是192.168.10.82。cd到安装目录的conf目录,找到http.yaml。配置完后cd到安装目录的bin目录,执行数据库初始化。這裏的https_enable得改成true。),所以重开一个帖子,以便新手参考使用。









