logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

如何阅读大型verilog模块

以上,个人经验,欢迎讨论。

#fpga开发
ipynb转markdown的简单方法

推荐在线转换,拖进去后下载就行,简单易操作。

文章图片
#jupyter#ide#python
VCS开启-sverilog后用assign给reg赋值时不报错

但我没有查到sverilog中可以在assign中给reg赋值的信息,或许是sverilog选项开启后编译检查较为宽松所致。反过来将变量改成reg,使用assign给reg赋值时不会报错。使用always给wire赋值时会报错(如下图)删除-sverilog编译选项后问题解决。针对wire变量rd_data。正常报错(如上图)。

#硬件工程
openclaw 使用kimi api key 报错401

最初用qwen code配置百炼的千问code plan api key一切正常,但是使用kimi的code plan api key无论如何都配置不上,openclaw对话时候都报错 401,问kimi chat也没得到给出解决办法,不断修改过程中还遇到如下报错。

电脑没电关机,wsl和docker又挂了,附解决过程

provisioning docker WSL distros: terminating WSL distro "docker-desktop": exit code: 4294967295: running WSL command wsl.exe C:\windows\System32\wsl.exe --terminate docker-desktop: 不存在具有所提供名称的分发。打不开就算

文章图片
#docker#linux#windows
WSL调用docker

我的windows电脑安装了两种WSL,一种是ubuntu(通过cmd的wsl install命令安装),一种是ubuntu24(通过应用商店)但无论我如何折腾,我都没办法直接通过点击红色的ubuntu24图标进入的wsl 命令行运行docker,结果总是。希望在wsl里面运行docker,首先要安装docker在WSL中使用,大部分人的第一想法肯定是用以下命令行安装(个人不推荐)我不知道上面的命

文章图片
#docker#容器#运维
openclaw 使用kimi api key 报错401

最初用qwen code配置百炼的千问code plan api key一切正常,但是使用kimi的code plan api key无论如何都配置不上,openclaw对话时候都报错 401,问kimi chat也没得到给出解决办法,不断修改过程中还遇到如下报错。

docker容器中连接宿主机mysql数据库

创建网桥启动容器的同时绑定网桥同时设置固定ip​启动另一个服务​使用网桥的好处就是容器之间是共享网络的,双向的,比–link的方式要灵活,而且容器内ip可以指定号,更加可控。但这样有个问题,数据库不能持久化,每次更新应用都要更更新数据库,而且每个应用都带个数据库会导致资源浪费,所以需要把数据库放在宿主机器,但这样宿主机和容器网络要相通。上面的报错是说连接上mysql,但访问密码错了,但我确实是用r

#docker#mysql
openclaw 使用kimi api key 报错401

最初用qwen code配置百炼的千问code plan api key一切正常,但是使用kimi的code plan api key无论如何都配置不上,openclaw对话时候都报错 401,问kimi chat也没得到给出解决办法,不断修改过程中还遇到如下报错。

docker容器中连接宿主机mysql数据库

创建网桥启动容器的同时绑定网桥同时设置固定ip​启动另一个服务​使用网桥的好处就是容器之间是共享网络的,双向的,比–link的方式要灵活,而且容器内ip可以指定号,更加可控。但这样有个问题,数据库不能持久化,每次更新应用都要更更新数据库,而且每个应用都带个数据库会导致资源浪费,所以需要把数据库放在宿主机器,但这样宿主机和容器网络要相通。上面的报错是说连接上mysql,但访问密码错了,但我确实是用r

#docker#mysql
    共 15 条
  • 1
  • 2
  • 请选择