logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

idea项目注册在nacos错误:Cannot determine local hostname

一开始想把项目注册在nacos上,启动报错是这样的,而且yml文件也不生效,因为默认端口是8080,我在yml文件中写了8081没用,正好nacos的配置也在yml文件中。各种百度,各种依赖添加删除,反复启动没用。然后还是报错 Cannot determine local hostname。解决办法: 项目配置文件里加入忽略虚拟机网卡,重新启动就没有报错信息。晚上十一点多了,索性关机睡觉!第二天早

文章图片
#java#开发语言#intellij-idea
SpringCloud Alibaba实战和源码分析——Nacos2.1.0作为注册中心源码分析(8)

找入口的方式:自动装配类 spring.factories事件驱动:NacosAutoServiceRegistration实现了applicationListener接口判断变量 1、 debug 2、 全文搜索 定位赋值位置通过ephemeral的值判断是grpc通信,还是http通信,通过这我们能判断ap模式是用的grpc模式,cp模式是用http通信判断服务端处理类的方式,我们可以根据请求

#spring cloud#spring boot#后端
SpringCloud Alibaba实战和源码分析——Nacos2.1.0作为配置中心使用和源码分析(9)

官方文档:Nacos 提供用于存储配置和其他元数据的 key/value 存储,为分布式系统中的外部化配置提供服务器端和客户端支持。使用 Spring Cloud Alibaba Nacos Config,您可以在 Nacos Server 集中管理你 Spring Cloud 应用的外部属性配置。

#spring cloud#spring#后端
git clone的地址。错误fatal: destination path ‘xxx‘ already exists and is not an empty directory.

如果报错如上图,执行以下命令查看文件,删除即可重新clone。

文章图片
#git
Idea2023.3版本创建spring Initializr没有JDK8

解决方法:https://start.aliyun.com

#intellij-idea
Ruoyi框架使用

或者直接用我下载好的通过网盘分享的文件:Car链接: https://pan.baidu.com/s/19uY8eRp3Gvu5GIgLaViTAA?pwd=1234 提取码: 1234。

Linux中yum错误:Loaded plugins: fastestmirror, langpacksLoading mirror speeds from cached hostfileCoul

报错如下:运行yum makecache依然报错!猜测就是yum有问题了,找了几个小时终于找到一个正确的解决办法:① 依次执行如下命令② 更换yum镜像源为阿里云③ 清空yum缓存,重新执行yum makecache命令即可然后我运行我要运行的命令成功了。

#linux#运维#服务器
到底了