logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

【centos7安装zabbix4.0】

修改zabbix-server配置文件/etc/zabbix/zabbix_server.conf,秩序修改其中DBPassword即可。安装zabbix-server,httpd,php。启动mariadb,不然没有socket。创建zabbix用户和库。

文章图片
#zabbix#mysql
【centos8安装zabbix-server6.0】

一开始我想在alios2.1(centos7)上安装zabbix-server6.0,但是到导入server.sql.gz文件时发现没有这个文件,但是zabbix-server-mysql却能安上,后来发现其实安装的是alios自带的zabbix60-server-mysql这个是没有server.sql.gz文件的,于是只能重装了一个alios3.2(centos8)来部署zabbix6.0。

文章图片
#zabbix#mysql
【-bash: cannot create temp file for here-document: No space left on device】

磁盘空间不足导致,df -h看一下清理磁盘空间解决。

文章图片
#linux
[sudo: a terminal is required to read the password; either use the -S option to read from standard ]

因为zabbix_get是zabbix用户调用的脚本所以会产生权限问题,在脚本的命令里加了sudo或提示上述告警,提示使用root权限需要输入root密码。在/etc/sudoers中添加如下配置,保存退出。zabbix_get 调用脚本时提示。zabbix_get执行成功。

文章图片
#服务器#linux#运维
【clickhouse-server安装问题】

表面是权限报错,先检查权限,其实有可能是centos某些内核版本不支持启动参数导致。

#clickhouse
【k8s设置污点/容忍】

上面两部只能让pod容忍这个node,且node上不调度别的pod,但是目标pod还是会调度到别的节点上,所以需要nodeSelector来让pod固定到目标node上。这样,当node挂了时,pod消失,Deployment重现创建pod,再根据affinity打分,目标node为0分,pod调度到别的节点。一个应用占用的资源很大,而节点不是很大时,需要让这个应用单独占据一个节点,不让别的应用调

#kubernetes#java#容器
【k8s部署】

Kubernetes 版本:容器运行时:网络插件:一、所有节点基础配置以下操作需要在:全部执行。node1node2node3三、配置 hosts所有节点:测试:四、关闭防火墙所有节点:五、关闭 SELinux所有节点:临时关闭:永久关闭:六、关闭 swap所有节点:永久关闭:验证:Swap 应为:七、配置内核参数所有节点:加载模块:配置 sysctl:生效:八、同步时间所有节点:安装:启动:验证

#kubernetes#容器#云原生
【k8s部署】

Kubernetes 版本:容器运行时:网络插件:一、所有节点基础配置以下操作需要在:全部执行。node1node2node3三、配置 hosts所有节点:测试:四、关闭防火墙所有节点:五、关闭 SELinux所有节点:临时关闭:永久关闭:六、关闭 swap所有节点:永久关闭:验证:Swap 应为:七、配置内核参数所有节点:加载模块:配置 sysctl:生效:八、同步时间所有节点:安装:启动:验证

#kubernetes#容器#云原生
【grafana原生告警中心配置飞书机器人告警】

在grafana中的connect point中使用webhook的方式推送到飞书,始终无法触发告警,原因是grafana推送的格式飞书不识别,现有两种方式。

文章图片
#grafana#机器人
【openvpn windows客户端同时连接多个服务端】

openvpn windows客户端默认只能连一个服务端,如果连上一个的情况下连第二个会显示连接失败,因为openvpn的客户端其实是创建了一个网络适配器,连第二个的时候客户端会发现这个适配器被占用了,所以只要再创建一个就可以了。下载一个openvpn的虚拟网卡驱动。安装完成后在设备管理器中可以看到。然后同时连接就可以了。

文章图片
#运维
到底了