logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

2020-08-30问题解决思路与方案:后端传前端JSON(cookie)加双引号问题、令牌无限过期,MAC时间校准

利用set_cookie,后端向前端传json数据时,字符串会加上双引号参考https://blog.csdn.net/chinabestchina/article/details/80905750同样也是设置了一个邮箱地址,然后发现形如"abc"的字符串不会加双引号,但邮箱地址会加。原因是目前大多数浏览器所使用的cookie,对于特殊字符如@,是不兼容的,会自动加上双引号。解决方案有两种:方法1

#json#html
golang shell封装出现问题,多个linux命令执行exec.Command()报错

在用exec.Comand()的时候出现cat /etc/hosts都报错,显示没有这个文件或目录(no such file…),试了试其他命令也大多是过不了的。问了同事说如果环境变量没问题或者hosts没配错就是shell封装原:command := exec.Command(cmd, parameter)更改为:command := exec.Command("bash", "-c", c)调

harbor镜像仓库更换证书到底要改什么?argo报错竟也与证书有关(踩坑记录)

harbor更换证书需要用到fullchain.cer和xxx.key,另外argo的“entrypoint”报错也与未验证证书有关。

#ssl
yapi容器化docker部署以及mongodb容器的持久化挂载异常问题

通过docker形式部署yapi,需要准备一个mongodb,然后直接在一个空文件夹里写好Dockerfile,其中通过wget下载yapi的zip包。基本按照这篇文章:https://www.modb.pro/db/149666 来处理即可。

文章图片
#yapi#docker#mongodb
flask项目celery使用redis sentinel中遇到的坑

flask项目celery中报错Can’t reconnect until invalid transaction is rolled back发现是celery的程序中有一处db.session.commit()没有处理异常,添加try except和db.session.rollback()之后修复。

#flask#python#sentinel
unable to resolve docker endpoint: default orchestrator is kubernetes but unable to resolve

unable to resolve docker endpoint: default orchestrator is kubernetes but unable to resolve kubernetes endpoint: invalid configuration: no configuration has been provided查看docker desktop关闭Deploy Docke

通过monitors.xml修改显示缩放率scale

通过monitors.xml修改显示缩放率scale  在Fedora30上做gnome-shell-extension的测试时把显示scale从100%依次调到了200%、300%、400%。在400%时settings,file,terminal等开始点开闪退,查找log发现报错为scale。只能通过命令行尝试修改scale,因为diplay设置根本没法打开。  网上给出的解决办法包括重装..

#linux
到底了