Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

农夫 John 建造了一座很长的畜栏,它包括NN (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,...,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢

输入格式

* Line 1: Two space-separated integers: N and C * Lines 2..N+1: Line i+1 contains an integer stall location, xi

第一行:空格分隔的两个整数N和C

第二行---第N+1行:i+1行指出了xi的位置

输出格式

* Line 1: One integer: the largest minimum distance

第一行:一个整数,最大的最小值

样例
样例输入
5 3
1
2
8
4
9
样例输出
3
把牛放在1,4,8这样最小距离是3

这是一道分治题,比较经典

_____________________________________________________________________________

写作不易,点个赞呗!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

希望有人看!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
_____________________________________________________________________________

#include<bits/stdc++.h>
using namespace std;
int a[100005],n,m;
bool node(int x){x为间隔
	int nm=1,h=a[1];\\定义一个nm记录可以放牛的牛棚的个数,h为当前的牛棚位置
	for(int i=2;i<=n;i++){
		if(a[i]-h>=x){
			nm++;可以放牛的牛棚个数++;
			h=a[i];更新当前牛棚位置
		}
	}
	if(nm>=m)return 1;如果可以放牛的牛棚大于等于题目要放的牛的个数返回1
	else return 0;否则返回0
}
int main(){
	cin>>n>>m;
	for(int i=1;i<=n;i++){
		scanf("%d",&a[i]);
	}
	sort(a+1,a+1+n);把牛棚位置从小到大排序
	int l=0,r=a[n]-a[1];左端点l初始化为0,r初始化为最大间隔“最远的牛棚与最近的牛棚距离”
	while(l<=r){
	    int mid=(l+r)/2;
		if(node(mid))l=mid+1;
		else r=mid-1;	
	}
	cout<<r;
}

坚持第2篇

Logo

长江两岸老火锅,共聚山城开发者!We Want You!

更多推荐