logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

spark streaming kafka OffsetOutOfRangeException 异常分析与解决

job中使用Kafka DirectStream 读取topic中数据,然后做处理。其中有个测试job,停止了几天,再次启动时爆出了**kafka.common.OffsetOutOfRangeException**。下文记录下异常分析与解决过程。

#kafka#spark
elasticsearch出现TranslogCorruptedException导致shard不能启动的问题修复

在使用ES的过程中遇到以下问题:[2015-01-06 16:12:34,061][WARN ][indices.cluster] [node_141] [ips][4] failed to start shardorg.elasticsearch.index.gateway.IndexShardGatewayRecoveryException: [ips][4] fai

#elasticsearch#lucene
zeppelin打包失败 'Failed to execute goal com.github.eirslett:frontend-maven-plugin'

zeppelin 官网提供的binary包不支持yarn,需要自己打包。问题zeppelin打包:~/apache-maven-3.3.1/bin/mvn clean install -DskipTests一直build failure:[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.2

#yarn
spark job 独立的log4j配置方法

spark中提供了log4j的方式记录日志。可以在$SPARK_HOME/conf/下,将 log4j.properties.template文件copy为 log4j.properties 来启用log4j配置。但这个配置为全局配置, 不能单独配置某个job的运行日志。本文介绍spark (streaming) job独立配置的log4j的方法。设置方法spark job提交时可以在 --co

#spark#log4j
virtualbox centos虚拟机 配置静态IP

virtualbox centos虚拟机 配置静态IP的方法

#centos
到底了