logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

Nginx配置带证书代理https

在nginx.conf同级目录下创建文件夹ssl,用来放置证书,把访问对方需要的证书上传到ssl文件夹下,若证书是pem或cer在nginx.conf加上证书即可;然后重新启动nginx,即可通过访问此台服务器/xxx路由访问到https://xxx.com上。

文章图片
#运维#nginx
iptables基本管理,配置SNAT实现共享上网

iptables基本管理1.1 问题本案例要求练习iptables命令的使用,按照要求完成以下任务:关闭firewalld,开启iptables服务查看防火墙规则追加、插入防火墙规则删除、清空防火墙规则1.2 步骤实现此案例需要按照如下步骤进行。步骤一:关闭firewalld,启动iptables服务1)关闭firewalld服务器[root@proxy ~]# syste...

免安装版nginx,启动报错如下:./sbin/nginx: error while loading shared libraries: libpcre.so.0: cannot open share

免安装版nginx,启动报错如下:./sbin/nginx: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory解决办法:ln -n /lib64/libpcre.so.1.2.0 /lib64/libpcre.so.0

文章图片
#nginx
Nginx解决跨域,session,cookie无效

问题背景有需求是把两个项目a和b,在a项目中有页面需要调用b中的接口,两项目的域名不同,分别为a.com, b.com。这时候如果直接调用,显然跨域了。一番折腾之后,问题解决了,这里记录一下解决方法。解决方法第一步,解决跨域这个使用Nginx的代理功能即可,在a服务器的Nginx添加如下示例配置:location ~ /xxx/ {proxy_pass http://b.com;}这样就把路径中带

#nginx#linux
openresty + waf 搭建

Centos7安装Openresty通过yum安装在 /etc/yum.repos.d/ 下新建 OpenResty.repo 内容[openresty]name=Official OpenResty Repositorybaseurl=https://copr-be.cloud.fedoraproject.org/results/openresty/openresty/epel-releasev

Oracle 19c(19.3.0.0)完整安装教程(Windows+Linux双环境)

Oracle 19c(19.3.0.0)完整安装教程(Windows+Linux双环境)

文章图片
#oracle#linux#数据库
基于Gitlab+docker实现CI/CD

利用Docker、Gitlab、Gitlab Runner、SonarQube、Harbor、Jmeter、Maven、Java技术,搭建一个完整的 CI/CD 管道,实现当开发人员完成代码提交后,开始流水线工作,完成编译打包、单元测试、源码扫描、上传制品、部署服务到Docker容器、自动化测试工作。通过自动化构建、测试、代码质量检查和容器化部署,将开发人员从繁琐的手动操作中解放出来,提高团队的开

文章图片
#gitlab#docker#ci/cd
docker-compose部署Prometheus+Alertmanager并配置企业微信告警

docker-compose部署Prometheus+Alertmanager并配置企业微信告警

文章图片
#docker#prometheus
apollo 配置中心的安装与使用 (docker 部署)

一、简介Apollo(阿波罗)是携程框架部门研发的分布式配置中心,能够集中化管理应用不同环境、不同集群的配置,配置修改后能够实时推送到应用端,并且具备规范的权限、流程治理等特性,适用于微服务配置管理场景。官方github:https://github.com/ctripcorp/apollogiteeapollo: Apollo(阿波罗)是携程框架部门研发的分布式配置中心,能够集中化管理应用不同环

文章图片
#docker#容器#运维
    共 30 条
  • 1
  • 2
  • 3
  • 请选择