
简介
该用户还未填写简介
擅长的技术栈
可提供的服务
暂无可提供的服务
前提条件Spring Cloud应用已改造为从Consul中读取配置,且应用启动正常第一种方法使用配置类,在启动类上用注解引入,然后在需要地方注入配置类即可使用import lombok.Data;import org.springframework.boot.context.properties.ConfigurationProperties;/*** @author kevin* @date
问题描述:一般公司都有自己内部封装的jar包,大都是SNAPSHOT,不改版本号,但是会更新时间戳,那如何清除jenkins旧版本jar包,以避免代码引用了新的jar包,但是依赖还是旧的jar包,导致打包失败呢?方法一:去jenkins部署主机,找到jenkins所使用的maven仓库位置,如果没有修改maven的settings文件,一般是.m2/repository下,去对应的jar包目录删除
安装elasticsearch 5.x报各种错误, 其中遇到“max file descriptors [4096] for elasticsearch process likely too low, increase to at least [65536]”这个错误,参考网上的一些做法,如:#切换到root用户修改vim /etc/security/limits.conf# 在最后...
习惯了在idea的git插件里,查看项目已修改的文件,但是新版idea默认不展示了,用起来很难受。2. 在Advanced Settings开启Use Modal Commit Interface。1. 确保安装Git Modal Commit Interface插件并开启该插件。
前提是Win10已经安装好WSL2,且linux发行版已经安装docker安装wsl2hostwsl2host下载地址(https://github.com/shayne/go-wsl2-host/releases)下载完成后,以管理员身份运行命令提示符cmd,安装过程如下:> .\wsl2host.exe installWindows Username: <username...
解决办法:开启电脑文件后缀显示,hibernate.cfg.xml.txt重新命名为hibernate.cfg.xml。maven项目下,resources文件夹下明明有hibernate.cfg.xml文件,却还是报找不到文件,错误的原因是:存在的文件其实hibernate.cfg.xml.txt,是个纯文本文件,由于电脑没有开启。文件后缀显示,误以为是有hibernate.cfg.xml文件。

前提是Win10已经安装好WSL2,且linux发行版已经安装docker安装wsl2hostwsl2host下载地址(https://github.com/shayne/go-wsl2-host/releases)下载完成后,以管理员身份运行命令提示符cmd,安装过程如下:> .\wsl2host.exe installWindows Username: <username...
看了网上很多教程,都是下面的安装流程,但是在自己的虚拟机里都没有成功sudo pacman -S fcitx-im# 全部安装sudo pacman -S fcitx-configtool# 图形化配置工具sudo pacman -S fcitx-sogoupinyin提示的错误:错误:未找到目标:fcitx-sogoupinyin但是...
看了网上很多教程,都是下面的安装流程,但是在自己的虚拟机里都没有成功sudo pacman -S fcitx-im# 全部安装sudo pacman -S fcitx-configtool# 图形化配置工具sudo pacman -S fcitx-sogoupinyin提示的错误:错误:未找到目标:fcitx-sogoupinyin但是...







