
简介
该用户还未填写简介
擅长的技术栈
可提供的服务
暂无可提供的服务
一.生成证书证书本应是花钱买,客户端才能通过根CA仓库识别证书。如果是自定义生成的证书,客户端访问时,会提示不安全的链接 是否继续访问,或者客户端可以将证书导入自己的本地CA仓库。生成证书可以通过 openssl,或者jdk的工具keytool生成。使用openssl,参考:https://www.jianshu.com/p/0e9ee7ed6c1d,先生成虚拟的CA,再生成证书,再用CA为证书签
sonar是个平台,可以集成checkstyle,findbugs等插件。安装sonarsonar8以上的版本不支持mysql,先安装postgres数据库。启动sonar 指定数据库配置,挂载了一个文件夹(用来下载插件)docker run --name sonarqube -d -p 9000:9000 -e SONARQUBE_JDBC_USERNAME=sonar -e SONARQUBE
服务端项目不想搞前后端分离,又想用vuevue和elementui版本必须匹配。vue2 可以这样https://blog.csdn.net/milli236/article/details/80511044vue3
传统的hotvm,需要先启动 jvm 再载入 java 代码,然后再即时的将 .class 字节码编译成机器码,交给机器执行。通过打包插件会将项目打成jar包,jar里是class文件,包含自定义代码和maven引用的所有包。
3.新宝塔数据库的wp_options表里的ip都改为新ip,如果不改,用新域名访问会跳转到旧网站。1.宝塔网站迁移,有个一键迁移工具,参考官网。2.修改域名解析为新ip。网站迁移到新服务器步骤。

Tomcat Server.xml引环境变量通过catalina.bat 或catalina.sh文件引用环境变量,将环境变量设置为系统变量,再在server.xml引用系统变量。环境变量:catalina.bat设置 JAVA_OPTS,注意bat文件用%%,sh文件用${}引用Server.xml引用指定webapps下的项目启动webapps下文件夹很多,只想启动目标文件夹Host标签中的a
参考网上一些优秀开源项目和框架,谈谈常见的微服务认证、鉴权方案。内容有SecurityOauth2、单点登录cas、自定义拦截器开发、微服务间鉴权、令牌的存储方式、shiro由单体改动为微服务微服务认证、鉴权的目标:一次登录后,各微服务都能访问可对各微服务进行角色、接口等粒度的鉴权SecurityOauth2可能是seurity框架提供了一个微服务鉴权的直接解决方式,导致网上资料大部分都是此类方案
一。部署三部分组成:nginx-service,相当与service代理Pod,使用NodePort将sevice端口映射到宿主机,所有K8s的访问都通过这个端口Ingress-Controller,核心实现,有多种实现方式,如nginx、traefik等,可以试试traefik,更灵活但2.x版本资料少Ingress,一份文件,定义路由规则1. nginx-service创建nginx-serv
举例:方法a加锁用的是trylock,即可能加锁失败,方法b的业务也就可能失败,但如果方法c的业务一定要成功,那方法c就可以提前加锁用 lock方法,再调用方法a时加锁肯定成功,这样保证了方法c和a一定能成功。3.谨慎使用leaseTime参数,设置后watchdog不生效,到了leaseTime后、即使业务没执行结束,锁也会释放,如果此时其他线程加锁,可能造成线程不安全。举例场景:封装了方法a,








