logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

zookeeper集群部署后启动报错ZooKeeper JMX enabled by default...解决方案二

三节点zookeeper部署后无法正常启动,报如下错误:通过查看配置文件发现几个端口未打开,无法进行集群,具体如下:2888端口号是zookeeper服务之间通信的端口。3888端口是zookeeper与其他应用程序通信的端口。2181端口是zookeeper客户端请求接口。需要防火墙放开这三个接口,才可以部署集群的方式。

#zookeeper#集群
Linux系统环境变量文件(/etc/profile)设置后无法使用vim、vi等命令原因以及解决方法

在/etc/profile中添加了错误的PATH变量,会导致几乎所有的系统命令无法使用,比如会出现如下图所示错误提示:修复PATH变量其实很简单,就是重新给PATH变量赋值就可以了命令如下:export PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/us

#linux#vim
linux开放端口的方法

1.方法一:以打开3306端口为例:命令1:/sbin/iptables -I INPUT -p tcp --dport 3306-j ACCEPT命令2:/etc/rc.d/init.d/iptables save命令3:/etc/init.d/iptables status命令4:service network restart方法二:直接修改/etc/sysconf

#linux
CentOS6.6下安装VMware Tools

为了方便虚拟机和主机之间复制粘贴文件,拖拽文件,需要安装VMware Tools。下面将我的安装步骤记录如下:第一步:打开虚拟机后,在VM的工具栏中点虚拟机——安装VMware Tools(T)...接着CentOS系统会自动挂载VMWare  Tools,并自动打开,如下图所示:第二步:为了方便,把VMware Tools-9.9.0-2304977.tar.

#centos
到底了