logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

zabbix发送告警邮件

前言之前文章已经介绍了如何离线安装zabbix及如果在grafana上炫酷的显示出来,但是由于grafana上不支持zabbix数据源报警,所以咱们还是在zabbix配置邮件报警;具体步骤如下:系统环境系统版本:centos7.6zabbix版本:4.4.1服务端ip:192.168.0.226客户端ip:192.168.0.226一、安装配置mailx1、安装mailx。yum install

#linux#centos#zabbix +1
gitlab备份恢复及迁移

1. Gitlab备份使用Gitlab一键安装包安装Gitlab非常简单, 同样的备份恢复与迁移也非常简单. 使用一条命令即可创建完整的Gitlab备份gitlab-rake gitlab:backup:create#备份git修改备份的目录和备份的时间vim /etc/gitlab/gitlab.rb修改完成后需要重新加载配置文件,重启gitlab。gitlab-ctl reconfigureg

文章图片
#gitlab#linux#运维
zabbix配置及grafana显示

zabbix配置及grafana显示前言:上篇文章已经介绍过如何离线安装zabbix了,这篇文章介绍一下配置zabbix监控及炫酷的显示在grafana面板上。系统环境:系统版本:centos7服务端ip:192.168.0.226客户端ip:192.168.10.62一、客户端配置1、首先需要在被监控的服务器上安装zabbix客户端,可自行在网上下载rpm包或者进行yum安装。本环境是离线环境,

#linux#centos#zabbix
修改docker的时间

一、前言创建完docker容器后,exec进入容器中发现时间跟主机时间不一致,从而导致各种问题。二、解决办法1、复制宿主机上的zoneinfo文件夹到容器下的/usr/share/目录下。docker cp /usr/share/zoneinfo 容器名称:/usr/share/2、 进入到容器中docker exec -it 容器名称 /bin/bash3、 创建软连接,修改时区。ln -sf

文章图片
#docker#linux
docker更改映射端口(实践篇)

一、系统环境操作系统:centos7.7docker环境:20.10.8二、docker中使用systemctl测试环境需要搭建一个php的网页,果断选择了docker部署,需要在docker中部署httpd服务,因为docker中默认不允许运行systemctl服务,所以会出现以下错误Failed to get D-Bus connection: Operation not permitted;

#docker#linux
gitlab访问502问题解决

系统环境:centos7.9(虚拟机)gitlab版本:11.1.4起因部署gitlab之后,浏览器访问出现502的错误,等待了几分钟后依旧不能解决,下面开启分析排查之旅。方向一:网上看到好多说法是因为内存太小导致的,由于本环境在虚拟机上搭建,内存就给了1G,果断增大内存试一下。当内存增大到3G后,问题依旧没有解决,因为是刚搭建的新环境,所以感觉不是内存的问题,换个方向继续排查。方向二:怀疑是端口

文章图片
#gitlab#linux#运维
清除nginx连接数TIME_WAIT

系统环境:操作系统:centos7nginx版本:1.12事件起因:由于环境是部署在阿里云上的,有添加云监控报警,最近一直在报警:提示nginx的tcp连接数已经超出设置范围,然后实际上没有很多的连接,于是开启了排查解决之旅。排查工作:本机的nginx环境是用来做代理和负载的。1、想起nginx有个长连接的配置参数,是不是配置时间太长导致连接没有释放导致的呢?结果发现,最大连接数设置了10240,

文章图片
#nginx#linux#运维
gitlab访问502问题解决

系统环境:centos7.9(虚拟机)gitlab版本:11.1.4起因部署gitlab之后,浏览器访问出现502的错误,等待了几分钟后依旧不能解决,下面开启分析排查之旅。方向一:网上看到好多说法是因为内存太小导致的,由于本环境在虚拟机上搭建,内存就给了1G,果断增大内存试一下。当内存增大到3G后,问题依旧没有解决,因为是刚搭建的新环境,所以感觉不是内存的问题,换个方向继续排查。方向二:怀疑是端口

文章图片
#gitlab#linux#运维
部署k8s集群(k8s集群搭建详细实践版)

k8s集群的搭建过程,本人实操记录,图文并茂,非常详细!

文章图片
#运维#kubernetes
到底了