logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

gitlab批量新增用户

gitlab开放了restApi,只要获取管理员的private_token之后就可以编写shell脚本免登陆通过api操作新增用户。

文章图片
#linux#gitlab
flinkCdc的mysql配置及java测试代码

测试使用的是flinkCdc2.1.1版本(无锁同步,1.x版本有同步锁)目前支持mysql5.7及以上版本;要在mysql.cnf中配置开启开启mysql的bin-log日志,log_bin=mysql-binbinlog_format=ROW并且只支持ROW格式,其他mixed和statement会报错如果想配置控制binlog日志的范围,在数据库范围可以使用mysql的binlog-do-d

文章图片
#mysql#数据库#database
树莓派安装摄像头、耳机、话筒

买了摄像头(500万像素很不清晰)、树莓派喇叭(声音很小稍微远点根本听不见)、话筒然后自己百度摸索安装;一、摄像头安装摄像头接线插到耳机孔后面的那个摄像头插口里(先把黑色的挡排轻轻拉起,摄像头线插进去之后再摁下去压住),设置下开启摄像头,然后通过命令可以拍照和拍摄视频。sudo raspi-config选择是然后重启树莓派 sudo reboot拍照运行命令raspistill -o image.

无法获取保存在session中的验证码

我在servlet里把验证码保存在session中了,  request.getSession().setAttribute("verifyCode",verifyCode);   但是在action中 用String verifyCode = request.getSession.getAttribute("verifyCode&quo

#servlet
setInterval定时连接后台防止session失效

每隔一段时间用ajax连接一次后台激活session防止session时间过长而失效:Code:"text/javascript">      //--begin--防止session失效ajax定时连接后台激活session      function alive(){          window.setInterval("

#ajax
quartz集群重复调度的解决

https://segmentfault.com/a/1190000015492260#quartz在触发时是乐观锁存在ABA问题,在配置文件加上org.quartz.jobStore.acquireTriggersWithinLock=true,这样,在拉取待即将触发的triggers时,是上锁的状态,不会同时存在多个线程拉取到相同的trigger的情况,避免了复调度的危险。...

文章图片
#java#开发语言#后端
clickhouse创建分布式数据库和分布式表

前提:有多个clickhouse节点并在metrika.xml配置分片和副本。-- 查询cluster集群名称 比如nx_clickhouse_4shards_1replicasselect * from system.clusters;dropdatabase test on cluster nx_clickhouse_4shards_1replicas ;create database tes

#数据库#分布式#sql
flinkCdc捕获postgresql增量日志

import com.ververica.cdc.connectors.postgres.PostgreSQLSource;import com.ververica.cdc.debezium.JsonDebeziumDeserializationSchema;import org.apache.flink.api.common.eventtime.WatermarkStrategy;import

#postgresql#数据库#database +1
树莓派设置固定ip

方法一:窗口操作设置静态IP1、右键点击打开右下角的无线网络图标,会弹出一个小菜单项,单击WiFiNetworks(dhcpcdui)Setting。2、在打开的NetworkPreferences窗口内,Configure项选择SSID,这时后面列表框内就会列出附近的WiFi网络列表,选择自己的网络SSID。然后设置ip3、勾选下面的Automaticallyconfigureemptyopti

文章图片
#tcp/ip#网络#网络协议
quartz锁表misfire的处理策略设置

因数据库锁表导致quartz无法更新数据库而报错,流程未调度。根据异常信息定位到quartz源码报错位置。Quartz原理解密https://www.cnblogs.com/Dorae/p/9357180.html结合网上介绍和源码分析为触发器更新事务失败。MisfireHandler线程会定时(50s)处理超时未触发的触发器,并根据misfire策略恢复触发器。但不知道设置misfire策略的地

    共 54 条
  • 1
  • 2
  • 3
  • 6
  • 请选择