logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

nginx-rtmp-module授权机制实现直播推流多房间授权认证

假设nginx直播服务器已经搭建完毕,如果还没有搭建完毕可以查阅利用nginx的nginx-rtmp-module搭建流媒体直播服务器这篇文章。在开发直播项目时推流应该是需要做权限认证的,不是任何人都可以随意向直播服务器推流,这就需要权限认证,实现起来也不复杂,只需要在nginx配置文件中的rtmp->server->application 下配置on_publish选

利用nginx的nginx-rtmp-module搭建流媒体直播服务器

Nginx除了做web服务器之外在流媒体方面的支持也是有对应的模块,nginx-rtmp-module就是nginx的一个扩展模块,支持rtmp视频推流,同时利用nginx作为web服务器的有时可以很方便的实现直播拉流,项目官方地址是https://github.com/arut/nginx-rtmp-module。下面简述一下安装过程。首先需要下载或者克隆代码#下载wget https:...

#swoole
Linux负载均衡简单配置

修改ip地址 vi /etc/sysconfig/network-scripts/ifcfg-ens33调度机CentOS修改为192.168.67.129修改 vi /usr/local/nginx/conf/nginx.conf upstream www.bbs.com{               server 172.20.10.13:80 weight=1;       //...

#负载均衡
HTTPS站点使用WebSocket的常见错误及解决方案

因为HTTPS是基于SSL依靠证书来验证服务器的身份,并为浏览器和服务器之间的通信加密,所以在HTTPS站点调用某些非SSL验证的资源时浏览器可能会阻止。比如使用ws://***调用websocket服务器或者引入类似http://***.js的js文件等都会报错。这里简述一下连接websocket服务器时的错误及解决方案。当使用ws://连接websocket服务器时会出现类似如下错误:Mi..

#swoole
到底了