logo
publist
写文章

简介

该用户还未填写简介

擅长的技术栈

可提供的服务

暂无可提供的服务

网络传输过程、参考模型、TCP/IP、http、https

OSI七层概念模型应用层:负责解决业务问题表示层:负责把网络中的消息转换成应用层可以读取的消息会话层:负责建立会话、握手、维持连接、关闭传输层:负责解决进程与进程之间的通信,例如TCP保证报文的可达性和流量的控制网络层:负责解决广域网(Internet)中主机之间数据的传递数据链路层:负责局域网中根据MAC地址连接的相应的交换机/路由器进行报文的转发物理层:物理传输介质TCP/IP模型对照分层模型

#http#https#计算机网络
http get 请求地址传中文或值带特殊符号解决方法 URLEncoder.encode(str,"编码") new URLDecoder().decode(str,"编码")

get 请求调用原本 对象的值为json类型   {}导致请求报错 URLEncoder.encode(str,"编码")JSONObject jsonObject = JSONObject.fromObject(mapparams);URLEncoder.encode(jsonObject.toString(),"UTF-8");

设计模式-装饰模式(包装模式Wrapper)、装饰模式示例

装饰者模式又名包装模式(Wrapper),是一种对象结构型模式。是一种用于替代继承的技术,他通过一种无需定义子类的方式来给对象动态增加职责,使用对象之间的关联关系取代类之间的继承关系实际就是动态地给一个对象添加一些额外的功能,比生成子类要灵活优点:装饰类和被装饰类可以独立发展,不会相互耦合,装饰模式是继承的一个替代模式,装饰模式可以动态扩展一个实现类的功能。缺点:多层装饰比较复杂。使用场景: 1、

#设计模式#java
Spring Cloud Alibaba Sentinel 1.8.0(四)服务降级

除了流量控制以外,对调用链路中不稳定的资源进行熔断降级也是保障高可用的重要措施之一。一个服务常常会调用别的模块,可能是另外的一个远程服务、数据库,或者第三方 API 等。例如,支付的时候,可能需要远程调用银联提供的 API;查询某个商品的价格,可能需要进行数据库查询。然而,这个被依赖服务的稳定性是不能保证的。如果依赖的服务出现了不稳定的情况,请求的响应时间变长,那么调用服务的方法的响应时间也会变长

容器服务Kubernetes或jenkins 414问题

访问414是因为请求头参数过长的错误,解决办法为加大client_header_buffer_size 和large_client_header_buffers的配置,需要修改nginx配置项我这里使用的是k8s,如果jenkins 也是同样的道理如果是多层nginx则需要定位问题产生源的层级如下是我的问题产生。#mermaid-svg-DYoolmN8l5OtXAto .label{font-f

微信开发IOS系统的一些坑(JS 正则表达式验证)

IOS系统不支持JS正则输入框 验证纯汉字输入   ios系统输入先在输入框呈现英文字母在转换成汉字纯数字限限制可能会跳出Input输入框限制   出现isNaN();验证非数字类型    详细可参考http://blog.csdn.net/extraordinarylife/article/details/52859574window.history.go(-1); //返回

docker Skywalking(二)配置告警信息回调指定url、自定义链路跟踪、集成logback输出traceId日志

配置告警信息进入容器,操作如图vi alarm-settings.yml编辑规则,修改回调方法。在docker容器中更推荐挂载此文件。规则说明# 警报规则rules:# 规则的唯一名称,必须以`_rule`结尾。service_sla_rule:

分分钟学会eclipse 配置Jad反编译插件下载安装教程

1. 先在网上下载Jd-eclispe插件的压缩包,下载地址为:官网:http://java.decompiler.free.fr/2. jdeclipse_update_site.zip下载好了之后,解压,将plugins文件下的jd.ide.eclipse_0.1.3.jar和jd.ide.eclipse.win32.x86_0.1.3.jar复制到eclipse安装目

redis docker搭建主从复制

docker run -p 6381:6379 --name redisMaster -v /home/tools/redis/masterSlave/master/redis.conf:/etc/redis/redis.conf -v /home/tools/redis/masterSlave/master/data:/data -d redis:6.0 redis-server /etc/re

#redis
docker容器挂载 No such file or directory

此问题一般是因为容器挂载直接指向了一个顶级目录,导致的例如一个想挂载到宿主机/home/config下,如果/home/config还有子目录容器启动的时候就会报错…No such file or directory

    共 24 条
  • 1
  • 2
  • 3
  • 请选择