
简介
该用户还未填写简介
擅长的技术栈
可提供的服务
暂无可提供的服务
今天遇到pom中添加dependency时相关的jar会自动下载,但是左边的External Libraries中一直获取不到添加的jar问题。刚开始怀疑是maven的更新问题所以一直在下边这几个地方重复的执行,然而并未有卵用。后来在网上查的:在这里更新,一样没用,而且这个位置的跟上边是一个功能。这里的reimport主要是针对maven没有使pom的引用自动更新而执行的手动更新功能,这点比
今天使用docker安装rabbitmq的时候按照参考书上的执行,但是在web的管理页面一直无法显示。docker run -d --name myrabbitmq -p 5673:5672 -p 15673:15672 docker.io/rabbitmq:latest执行完后,查看容器已经是正常运行的。
如果仅仅是master-slave模式可以参考我前边的文章Spring Boot HikariCP集成多数据源。这篇文章也是在那个基础上修改的,上篇文章中的多数据源是有限制的,哪条sql使用哪个数据库必须在代码中写死。现在针对这点做优化,真正的集成多个数据源,且实现简单的负载均衡。相关主要代码先看配置文件slave:hosts: slave1,slave2hikar...
最近在弄项目混淆的,proguard是最为广为使用的工具之一,可是用他的客户端来混淆springboot项目的时候最后总得不到可执行的jar。后来发现了proguard-maven-plugin这个插件,所有proguard的指令都可以在pom中实现,正好在github上也找到了参考项目,这里给大家分享下。直接看pom:<build><finalName>${artifactId}
在安装好rabbitmq的时候会默认给出用户名和密码guest/guest在项目中连接的时候设置如下:如果想要修改或者添加用户可以在web管理页面进行设置:使用guest用户登录之后点击admin可以进入用户管理页面。这里我添加了两个账号rabbit和test,其中rabbit是设置了对rabbitmq的访问权限,test没有设置。如果在
用docker启动redis的时候出现以下异常:[root@centos7 redis]# docker run -d -p 6379:6379-v $PWD/data:/dataredis --appendonly yesd06e8905aeb84458e5930e086f0a087d2ef35774c0cc6a3e1ff9f74b5925a80b[root@centos7 ...
其实这里介绍的东西主要是参考的另外一篇文章,数据库读写分离的。参考文章就把链接贴出来,里面有那位的代码,简单明了https://gitee.com/comven/dynamic-datasource-demo?spm=5176.100239.blogcont188540.13.iARYDh。读写分离的功能我已经使用replication集成好了,因为我们需要单独设置每个数据源的链接属性,而且使用的
准确来说应该是今天升级了阿里云的ECS内存之后重启实例,结果发现所有跟docker相关的东西都坏掉了。docker启动不了,所有镜像都查不到。我们的gitlab是用的docker,所以必须要把这个给弄好。查看docker相关的文件和镜像容器都在,所以猜测数据可能没受到损坏。具体修复过程分为以下几个阶段:1、这是由于重启了服务器造成的,所以有可能再重启一次情况会回复,但是重启后结果还是不行。
今天建立docker容器的时候由于疏忽,镜像的名字输错了,结果容器创建成功后,镜像中出现两个id相同的:使用docker rmi e4a35914679d删除的时候执行失败:Error response from daemon: conflict: unable to delete e4a35914679d (must be forced) - image is referenced in
默认要安装activemq的主机上已经安装了docker.查询activemq:docker search activemq我使用的是阿里云的仓库,所有查出来跟使用官方的稍微不一样,但是拉去镜像的时候都是按照name。docker pull docker.io/webcenter/activemq在不加tag的情况下默认使用latest,在不知道tag的情况下最







