题目1143:Primary Arithmetic

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:421

解决:164

题目描述:

    Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number of carry operations for each of a set of addition problems so that educators may assess their difficulty. 

输入:

    Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.

输出:

    For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.

样例输入:
123 456
555 555
123 594
0 0
样例输出:
NO carry operation.
3 carry operations.
1 carry operation.
 
    
#include<iostream>
using namespace std;
 
int main()
{
    int n,m,c,t;
    while(cin>>n>>m&&n&&m)
    {
        c=t=0;
        if(n<m){ n=n+m;m=n-m;n=n-m; }
        while(m>0)
        {
            if(m%10 + n%10 + c >9 ){ c=1; ++t;}
            else c=0;
            m/=10;
            n/=10;
        }
        while(n>0)
        {
            if(n%10 + c > 9){c=1;++t;}
            else c=0;
            n/=10;
        }
        if(!t)cout<<"NO carry operation."<<endl;
        else if(t==1)cout<<t<<" carry operation."<<endl;
        else cout<<t<<" carry operations."<<endl;
    }
    return 0;
} 
/**************************************************************
    Problem: 1143
    User: 3011216016
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:1520 kb
****************************************************************/


Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐