A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题解:题目给出数字和进制,如果该数字在该进制转换后为回文数,则输出“Yes”并输出转换后的结果,如果不是回文数输出“ No”和转换后的结果。

代码:

#include<bits/stdc++.h>
using namespace std;
bool judge(int z[],int num)
{
    for(int i=0;i<=num/2;i++)
        if(z[i]!=z[num-1-i])
        return false;
    return true;
}
int main()
{
    int n,b,z[40],num=0;
    cin>>n>>b;
    do
    {
        z[num++]=n%b;
        n/=b;
    }while(n!=0);
    bool flag=judge(z,num);
    if(flag)
        cout<<"Yes"<<endl;
    else
        cout<<"No"<<endl;
    for(int i=num-1;i>=0;i--)
    {
        cout<<z[i];
        if(i!=0)
            cout<<" ";
    }
    return 0;
}

 

Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐