Description

SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r, xy <-> u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.

Now your task is to write a program to change f into g.
 

Input

The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.
 

Output

For each input function, print its correspondent linear function with 9 variables in conventional way on one line.
 

Sample Input

 
   
2 0 46 3 4 -5 -22 -8 -32 24 27 2 31 -5 0 0 12 0 0 -49 12
 

Sample Output

 
  

46q+3r+4u-5v-22w-8x-32y+24z+27 2p+31q-5r+12w-49z+12

 


注意:

1.当输入的是1或-1时,省略字母前面的1或-1
2.如果全是0 输出0

代码:一开始一直忽视了输出一个负的之后要把flag变成1,下一个正数才有加号
#include <stdio.h>
#include <string.h>
#include<string.h>
#include<iostream>
int main()
{
    int t,flag;
    int c[15];
    char a[15]={'p','q','r','u','v','w','x','y','z'};
    scanf("%d",&t);
    while(t--)
    {
        int d=0;
        flag=0;
        for(int i=0;i<=9;i++)
        {
            scanf("%d",&c[i]);
            if(c[i]==0)
                d++;
        }

        for(int i=0;i<=9;i++)
        {
            if(i!=9)
            {
               if(c[i]==0)
                 continue;

                else if(c[i]==1)
                {
                    if(flag==0)
                    {
                         printf("%c",a[i]);
                         flag=1;
                    }
                    else
                      printf("+%c",a[i]);
                }
                else if(c[i]>0)
                {
                    if(flag==0)
                    {
                         printf("%d%c",c[i],a[i]);
                         flag=1;
                    }
                    else
                      printf("+%d%c",c[i],a[i]);
                }
                else if(c[i]==-1)
                {
                    printf("-%c",a[i]);
                    flag=1;
                }
                else
                {
                    printf("%d%c",c[i],a[i]);
                    flag=1;
                }

            }
            else
            {

                if(c[i]==0)
                {
                    if(d==10)
                        printf("0");
                    else
                        continue;
                }
                else if(c[i]>0)
                {
                    if(flag==0)
                    {
                         printf("%d",c[i]);
                         flag=1;
                    }
                    else
                      printf("+%d",c[i]);
                }
                else
                    printf("%d",c[i]);
            }
        }


        printf("\n");
    }
    return 0;
}
Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐