1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

提交的代码

a=input()
sum=0
num=['zero','one','two','three','four','five','six','seven','eight','nine']
while (a):
    m=a%10
    sum+=m
    a=a//10
out=''
while (sum):
    n=sum%10
    out=num[n]+' '+out
    sum=sum//10
out= out[:-1]
if not out:
    out= 'zero'
print out

结果

这里写图片描述

Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐