Rightmost Digit
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer N, you should output the most right digit of N^N.  
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.  
Each test case contains a single positive integer N(1<=N<=1,000,000,000).  
 

Output

For each test case, you should output the rightmost digit of N^N.  
 

Sample Input

     
     
2 3 4
 

Sample Output

     
     
7 6

Hint

 In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
N^N的最后一项是循环的,每二十个一循环,对二十取模就行
#include<stdio.h>
int a[21]={0,1,4,7,6,5,6,3,6,9,0,1,6,3,6,5,6,7,4,9,0};
int main()
{
	int t;
	__int64 n;
	scanf("%d",&t);
	while(t--)
	{int ans;
		scanf("%I64d",&n);
		ans=n%20;
	printf("%d\n",a[ans]);
	}
}


Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐