Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15506    Accepted Submission(s): 6021


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2. In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 

Author
Ignatius.L

思路:这道题目是参考网络上大牛们写的,想法就是N*N=M,那么M=10^ ( N*log10 (N) ),【取一次对数再取10的对数次方】
     又由于10^(a*b)【a为整数,b为小数】的最左一位数仅仅与b有关,===> 10^( c.d )[这c.d=a*b],也就是10^c*10^0.d次方,所以最高位仅 仅        受0.d的影响,所以有ans=ans-(int)ans , ans=N*log10(N), 再求( int ) 10^ans,就是答案了。膜拜数学大牛。。
AC代码如下:
#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;


int main(){

    double a,ans,tmp;
    long long ttmp;
    int t;
    cin>>t;
    while(t--){
        cin>>a;
        tmp=a*log10(a);
        ttmp=(long long)tmp;
        ans=tmp-ttmp;
        cout<<(int)pow(10.0,ans)<<endl;
    }


    return 0;
}



Logo

瓜分20万奖金 获得内推名额 丰厚实物奖励 易参与易上手

更多推荐