For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174

… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,104).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

#include<iostream>
#include<algorithm>
#include<iomanip>

using namespace std;

bool cmp(int a, int b){
	return a > b;
}

int b[4] = {0};
void to_array(int a){
	int i = 0;
	while(a != 0){
		b[i] = a % 10;
		a /= 10;
		i++;
	}
}

int to_number(int b[]){
	int sum = 0;
	for(int i = 0; i < 4; i++){
		sum = sum * 10 + b[i];
	}
	return sum;
}

int main(){
	int n, min, max;
	cin >> n;
	while(1){	//不能在这里判断,输入的值可能为0或者6174
		to_array(n);
		sort(b, b + 4);
		min = to_number(b);
		sort(b, b + 4, cmp);
		max = to_number(b);
		n = max - min;
		cout << setw(4) << setfill('0') << max << " - " //不足4位的数,在高位补0
			<< setw(4) << setfill('0') << min << " = " 
			<< setw(4) << setfill('0') << n << endl;
		//printf("%04d - %04d = %04d\n", max, min, n);
		if(n == 0 || n == 6174) break;
	}
	return 0;
}
Logo

旨在为数千万中国开发者提供一个无缝且高效的云端环境,以支持学习、使用和贡献开源项目。

更多推荐